Back to overview
Degraded
We’re experiencing degraded performance — we’re actively investigating.
May 1, 2026 at 7:13am UTC
Affected services
Platform & API
Resolved
May 1, 2026 at 7:35am UTC
The performance issue has been resolved. We are currently investigating the root cause of the incident.
Affected services
Created
May 1, 2026 at 7:13am UTC
The platform may still be loading. Your data might not be visible.
Affected services